Digital RX01 floppy drive (Computertechniek)

door Roland Huisman @, Zwolle, 03-01-2021, 10:14 (17 dagen geleden)

Afgelopen maandag had ik een mooie Digital RX01 floppy drive mee naar huis gesleept.

Omdat ik toch moest wachten op onderdelen uit de US voor een ander project, bedacht ik
mij dat ik wel even snel naar die RX01 kon kijken. Nou dat 'snel' kon ik snel vergeten :-)
Want toen ik hem neerzette hoorde ik al iets klepperen in de kast. Dat bleek de bovenste
print te zijn die los lag. Dus is hij eerst maar even op de sofa gaan liggen en heeft
zijn levensverhaal gedaan... De drive ziet er allereerst erg goed uit.

[image]

[image]


Iemand heeft alleen de datakabel gestolen vanaf het bord naar de connector achterop de kast.
Geen man overboord, is zo na te maken.

[image]


De bovenste print zat dus niet vast. Iets met US schroefjes die ik altijd te
weinig heb. Ook de onderste print zat maar met twee schroefjes vast.
Blijkbaar moesten ze "ergens" vaak bij? Of te lui om alles weer vast te zetten?

[image]

Toen zag ik deze groene connector... Is dat voor de KM11 testinterface met lampjes?

[image]

't zal toch niet zo bedoelt zijn?

[image]

Ja dus wel :-D :-D :-D

[image]

Toch maar eens onderin kijken hoe de snaren zijn en hoe de lagers klinken.
Hmm één vieze plakboel... Heeft iemand lagers willen smeren? Snaar er afgehaald en een
slinger aan het vliegwiel gegeven... GRAUWWWW Vooral de lagers van DX0 zijn total loss...

[image]

De spindel heeft twee lagers, onder en boven. Vooral de onderste is slecht. Maar beide gaan er uit.

[image]


Automonteur... Iemand?

[image]


En het lager bovenin niet vergeten, daar heb ik al eens een floppy mee stuk getrokken...

[image]

En ja, ook tochtstrip is na 45 jaar niet meer wat het geweest is. Dat moet de hoes van de flop
net naast de kop aandrukken. Dat kan het viltje aan de andere kant van de disk niet alleen...

[image]


Nou ja, snel nieuwe lagertjes met 15% feestdagenkorting besteld.
Tochtband slingert nog wel ergens en voor die datakabel is het spul wel in huis.

En ik heb de drive gelijk maar even zwemles gegeven. Hij moest aardig ver uit elkaar
om bij de diverse items te komen. Dan is dit maar een kleine stap extra.

[image]

Alleen het was mij niet helemaal duidelijk wanneer ik die reinigingsdisk er bij in moest gooien... ;-)

[image]


Ook maar voorkomen dat dit soort dingen weer rotzooi door de drive heen blazen...

[image]


Al was vuurwerk verboden, toch maar even een exploded view gemaakt! :-D

[image]


En de lagerboer had met turbosnelheid de nieuwe lagers geleverd! 30e besteld, 31e al binnen!

[image]


Altijd maar weer afwachten of je de juiste lagers erbij hebt gevonden.
Die oude nummers op de lagers zijn niet gangbaar meer. Maar ze passen mooi :-)

[image]


Nieuw luchtfiltertje, lang leve wasemkapdoek...

[image]


Nieuw foam om de disk aan te drukken

[image]


Dec gebruikte veel Boxer fan ventilatoren. Die dingen zijn echt fantastisch weer te gebruiken.
Alleen je moet ze niet eerst uren droog laten lopen. Want ook hier het oliereservoir
(klein stukje vilt) helemaal uitgedroogd in de fan en is de as droog. Recept voor lawaai/slijtage...

[image]


Het aan/uit knopje ging wel heen en weer, maar ik miste de klik...
En het knopje bewoog ook maar moeizaam. Waarom verbaasd me dat niet?

[image]


Leek wel alsof iemand de vetspuit erop had gezet... Wat een bagger :-| De meeste drek kon ik er wel
uit scheppen met een schroevendraaier. Daarna een tijd laten zwemmen in de wasbenzine.
Het spul loste daarin op dus nu is hij weer schoon... En schakelt weer prima.

[image]


Alles weer snel in elkaar gepropt. Maar nu wel nieuwe spindellagers, nieuwe luchtfilters,
ventilatoren schoongemaakt, motorlagers gesmeerd, glijlager voor koppen gesmeerd,
koppen schoongemaakt, nieuw viltje om de disk aan te drukken én schoon knopje...

Dus nu een schone frisse drive welke in elk geval al mooi stil loopt. Hop in de testopstelling!

[image]


Maar we zijn er nog niet hoor... Doet nog geen head load... Ook geen -kloenk- bij het
resetten van de PDP11. Die -kloenk- ben ik van de RX02 gewent. Wellicht doet een RX01 dat niet?
Het testprogramma geeft ook duidelijk aan dat er geen INIT plaatsvindt.
Ik kan wel aan de KM11 zien dat er wat data heen en weer gaat... Snel even een
andere drive (RX02) aangesloten om te zien of mijn testopstelling wel werkte..
En dat ging wel goed. Okay, dus het is echt de RX01 drive zelf.

[image]


Na een kleine zoektocht bleek er een SN74194 defect te zijn.

[image]

En bingo! Toen kreeg ik als reactie "NO DRIVES READY" tijdens het draaien van de test.
Ja dat kon wel kloppen, ik had de drive nog op de kant staan zonder floppen erin.
Daarnaast hoorde ik nu ook de duidelijke KLOENK van de head load. Mooi!
Floppen er in en waarlijk, de hele test werd foutloos uitgevoerd :-)


[image]

Mooie gereviseerde floppydrive erbij -blij- :-D

Groeten, Roland


Complete draad:

 RSS Feed van berichtenreeks

powered by my little forum